Search found 413 matches

by lpaatero
Sun Oct 24, 2021 8:01 am
Forum: General
Topic: After JDK has been installed,but Gowrite says no usable JVM foumd
Replies: 1
Views: 9

Re: After JDK has been installed,but Gowrite says no usable JVM foumd

I assume you are using windows. In Windows the most recent JDKs have changed the ways they should be found. And it seems different JDKs should be found in different ways. This is a big mess. I have decided to integrate a JRE into gowrite. Please install the development version from download page, an...
by lpaatero
Thu Sep 30, 2021 5:28 pm
Forum: General
Topic: GOWrite 3.0.23
Replies: 0
Views: 152

GOWrite 3.0.23

GOWrite 3.0.23 changes: Windows installer contains embedded java (java version 17), no need to install java. Windows installer supports only 64bit windows. Graphics: Possibility to avoid lines between stones (typical in Chinese go books). Shortcut for export command. Minimum java requirement is Java...
by lpaatero
Tue Sep 28, 2021 9:16 am
Forum: Bugs
Topic: Error in GoWrite Launcher, No usable JVM found
Replies: 12
Views: 15457

Re: Error in GoWrite Launcher, No usable JVM found

There is now a test version of Windows GOWrite with java embedded ( https://gowrite.net/download/gowrite2_3_0_23.exe ). This installation does not require any java version installed. Internally this uses latest java (version 17). Let me know if this works! I have made only very limited testing. Upda...
by lpaatero
Mon Sep 27, 2021 6:40 pm
Forum: Bugs
Topic: Error in GoWrite Launcher, No usable JVM found
Replies: 12
Views: 15457

Re: Error in GoWrite Launcher, No usable JVM found

After JRE install and setting the registry keys gowrite should already work ok. It seems these JRE/JDK issues are getting only worse.

I will be looking at combining Java into gowrite install. This should remove the whole mess.

/Lauri
by lpaatero
Mon Sep 27, 2021 10:10 am
Forum: Bugs
Topic: Error in GoWrite Launcher, No usable JVM found
Replies: 12
Views: 15457

Re: Error in GoWrite Launcher, No usable JVM found

It seems openjdk has changed their stuff. In order to get needed JRE, one should go to page https://adoptopenjdk.net/releases.html and select windows / X64. Then download MSI package for JRE . It seems during install one must select "Install Oracle compatible registry keys" (or something l...
by lpaatero
Thu Sep 23, 2021 7:07 pm
Forum: Tips & Tricks
Topic: How to custom numbering without bold digits in export?
Replies: 3
Views: 250

Re: How to custom numbering without bold digits in export?

You can adjust fonts and many others things in "options" -> "layout and graphics options"
If basic options do not allow expected thing, advanced options probably do.

/Lauri
by lpaatero
Wed Sep 22, 2021 7:56 pm
Forum: Tips & Tricks
Topic: How to custom numbering without bold digits in export?
Replies: 3
Views: 250

Re: How to custom numbering without bold digits in export?

It looks like the numbers have been added as text labels into the SGF. This does not really work with GOWrite. One could try to tune it with "options" -> "layout and graphics options", but result will never be good. Normal way to create numbered sequence in SGF is to add diagrams...
by lpaatero
Wed Sep 22, 2021 7:44 pm
Forum: Tips & Tricks
Topic: Is there a way of binding "Export" to a shortcut?
Replies: 1
Views: 128

Re: Is there a way of binding "Export" to a shortcut?

Hi, GOWrite does not contain means to assign new shortcuts (easily). I think you may be seeing also a bug in java: https://bugs.openjdk.java.net/browse/JDK-8273310 If you want to experiment: Open GOWrite.app/Contents/Java/gowrite.jar (inside the gowrite app) as a ZIP file, and modify Accelerator-Mac...
by lpaatero
Mon Sep 06, 2021 8:45 am
Forum: Bugs
Topic: Error in GoWrite Launcher, No usable JVM found
Replies: 12
Views: 15457

Re: Error in GoWrite Launcher, No usable JVM found

Hi, I assume you installed 64-bit Java? Other than that, I have no idea what the problem could be. GOWrite uses registry settings to find the Java, so setting PATH is not needed for GOWrite. Can you try in installation directory (using command line) java -jar GOWrite.jar It is not good way to use GO...
by lpaatero
Mon Apr 26, 2021 7:13 am
Forum: General
Topic: GOWrite 3.0.19
Replies: 2
Views: 3606

Re: GOWrite 3.0.19

Thanks for the report! It seems AboutHandler was not available in Java 8. The best solution is to update to Java 11. Java 11 is most current LTS version, and seems to be available for most platforms, either from package management (linux) or from https://adoptopenjdk.net/ for Windows and Mac. I see ...
by lpaatero
Thu Apr 01, 2021 7:15 am
Forum: General
Topic: GOWrite 3.0.21
Replies: 2
Views: 2669

Re: GOWrite 3.0.21

Hi, Generally I move versions to stable only after getting some feedback the new features are working as expected. I do not have good testing coverage for GOWrite, so there could many different kinds of problems left. If I do not hear any feedback, I typically move version to stable after using it a...
by lpaatero
Wed Oct 28, 2020 6:33 pm
Forum: General
Topic: GOWrite 3.0.19
Replies: 2
Views: 3606

GOWrite 3.0.19

This version (3.0.19) is for new MAC OSX installation package.
Updates:
* 3.0.19 First 3.0 GOWrite for Java.
* 3.0.19-1 updates java support.
by lpaatero
Wed May 13, 2020 3:34 am
Forum: Bugs
Topic: Exporting Colletion in .tex format
Replies: 4
Views: 6679

Re: Exporting Colletion in .tex format

I can think of quite a many potential reasons for the problem. The wizard has quite many heuristics in it. It seems I need to reproduce the problem to solve it. Can you send sample of the sgf files to me (lauri.paatero@iki.fi)? Also could you send the export wizard options, they are located in Wizar...
by lpaatero
Thu May 07, 2020 7:25 pm
Forum: Bugs
Topic: Exporting Colletion in .tex format
Replies: 4
Views: 6679

Re: Exporting Colletion in .tex format

Hi,

To bit narrow the problem, cloud you test, if HTML export works?

regards
Lauri
by lpaatero
Wed Oct 09, 2019 11:24 am
Forum: Support
Topic: 【Mac OS】Unable to copy current diagram
Replies: 1
Views: 3984

Re: 【Mac OS】Unable to copy current diagram

Hi. You cloud try menu Edit -> Copy Wizard; this allows selection of different formats to copy to clipboard. There select "bitmap graphics" as format. If this works, menu Options -> Clipboard graphics allows selecting Bitmap graphics as default for the copy. It is possible that problem rel...